Kirby’s Extra Epic Yarn Requires A New Nintendo 3DS

By Jenni . September 17, 2018 . 10:30am

kirbys extra epic yarn

 

A new requirement has been revealed for Kirby’s Extra Epic Yarn, the Nintendo 3DS port of the Nintendo Wii game. Nintendo’s product page for the game says New Nintendo 3DS systems only. This means only people with a New Nintendo 3DS, New Nintendo 3DS XL, and New Nintendo 2DS XL would be able to play the game, which is an updated port with additional content and features.

 

Kirby’s Extra Epic Yarn is not the first Nintendo 3DS version of a Nintendo Wii game that requires a New Nintendo 3DS model to play. Xenoblade Chronicles was the first. In addition, Fire Emblem Warriors’ portable version could only run on the updated iteration of the system.

 

Kirby’s Extra Epic Yarn was announced during the September 2018 Nintendo Direct and will arrive on New Nintendo 3DS systems in 2019. Kirby’s Epic Yarn is immediately available for the Nintendo Wii.


Read more stories about & on Siliconera.

Video game stories from other sites on the web. These links leave Siliconera.

Siliconera Tests
Siliconera Videos

Popular