miitomo a Nintendo has updated the Miitomo website with information detailing who will be able to use the free application. People with Apple iOS devices will need iOS 7.0 or higher. The iPhone 4 is listed as the only incompatible device. As for Android users, Android 4.1 (Jelly Bean) is required. No specific, incompatible devices are listed, but Nintendo notes some won’t be supported. Nintendo also stated that people will need to be at least 13 to use Miitomo.

 

There has also been a clarification concerning Miitomo language options. There will be 11 at launch, with multiple variations of some of the 8 languages available. They are as follows.

  • Dutch
  • English (UK/Australia)
  • English (USA)
  • French (Canada)
  • French (France)
  • German
  • Italian
  • Japanese
  • Russian
  • Spanish (Latin America)
  • Spanish (Spain)

 

Miitomo will be available in March. It is currently possible to pre-register via the official website. People who do will be notified when the app is available and get My Nintendo Platinum Points. Those Miitomo pre-registration Platinum Points will expire six months after My Nintendo’s launch.

Jenni Lada
Jenni is Editor-in-Chief at Siliconera and has been playing games since getting access to her parents' Intellivision as a toddler. She continues to play on every possible platform and loves all of the systems she owns. (These include a PS4, Switch, Xbox One, WonderSwan Color and even a Vectrex!) You may have also seen her work at GamerTell, Cheat Code Central, Michibiku and PlayStation LifeStyle.

You may also like

More in Android